Back to overview
Document Templating (docx) is down
Sep 07 at 05:11am CEST
Affected services
Document Templating (docx)
Resolved
Sep 07 at 06:28am CEST
Monitor recovered
Affected services
Document Templating (docx)
Created
Sep 07 at 05:11am CEST
Monitor was temporarily affected. Docx was unaffected.
Affected services
Document Templating (docx)